we're sorry, but something went wrong

sahar's Avatar


24 Sep, 2020 09:04 AM


everything went ok, i followed the tutorial from youtube: https://www.youtube.com/watch?v=fp6IWXdKuds&t=1s
but the problem: i can't sign in (see picture).

I dont know where it went wrong, can you maybe help me. s.v.p.
kind regards,

  1. 1 Posted by sahar on 24 Sep, 2020 09:07 AM

    sahar's Avatar

    Youtube: "Kali Linux Arachni Web Application Security Scanner Framework install "

  2. 2 Posted by test on 19 Nov, 2020 12:18 AM

    test's Avatar

    In your arachni dir edit the file system/gems/gems/bycrypt-3.1.11/lib/bcrypt/engine.rb
    Line 51:

    • __bc_crypt(secret.to_s, salt)

    Line 51:

    • __bc_crypt(secret.to_s, salt).gsub(/(\n|\x00).*/, '')
  3. 3 Posted by Richard Berry on 05 Jan, 2021 04:44 PM

    Richard Berry's Avatar

    I tried the above workaround and it is still not working for me on KALI linux.

  4. 4 Posted by Test on 07 Jan, 2021 02:37 AM

    Test's Avatar
  5. 5 Posted by HoustonHacker on 11 Jan, 2021 08:03 AM

    HoustonHacker's Avatar

    nightly build works.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screenshot_2020-09-24_04-59-52.png 179 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac