Can't connect to Arachni Proxy on EC2 AWS instance

amanda.barbosa's Avatar

amanda.barbosa

11 Apr, 2018 02:03 PM

Hello, I'm running arachni with the proxy plugin on an Amazon EC2 instance. This is the command I run:

arachni https://example.com --plugin=proxy:port=8080,bind_address=machine_IP

On machine IP, I put the IP that I get when running ifconfig on the Amazon Machine. The proxy starts running OK.

I want to access the proxy using my local Firefox browser, so I go to Connection preferences, and I set the Proxy HTTP to the AWS machine global IP address, the one I obtain when running a dig command using the machine FQDN. I set the port to 8080 and that's it.

Then, I try accessing https://example.com, but I get the "MOZILLA_PKIX_ERROR_NOT_YET_VALID_CERTIFICATE " error on Firefox. I tried setting my local timezone to UTC (the same in which the Amazon Instance is), but the error keeps happening.

What am I doing wrong?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac