FYI, How to force the Arachni WebUI to listen on IPv4

Michael Embree's Avatar

Michael Embree

15 Jan, 2016 03:40 PM

This is an explanation for others rather than a question. It results from an issue I had and found the answer to. Maybe it could be added to the Arachni KB.

On some hosts the Arachni WebUI will default to listening for connections on IPv6. To force the WebUI to listen on IPv4, start it with the --host parameter as follows:

arachni_web --host

If you are accessing the Arachni WebUI via HTTPS using a HTTPS reverse proxy running on the same host and don't want the Arachni WebUI to be directly accessible via HTTP, change the host IP from to Don't use localhost instead of as it may resolve to the IPv6 localhost address.

Instead of specifying the host parameter as a command line parameter, it can also be supplied via the system/arachni-ui-web/ file. Add the following line immediately below the comment line at the beginning of

#\ --host
#\ --host

A tip, arachni_web --help will show the available parameters.

  1. Michael Embree closed this discussion on 15 Jan, 2016 03:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac