arachni rpcd and Docker

bewell's Avatar


07 Dec, 2015 01:19 PM


I'm not entirely sure whether I should ask you, but maybe you tried Docker by yourself.
I want to launch Arachni rpcd server using docker and I'm experiencing a situation that rpcd cannot (?) start fully. In the console it outputs the version number and that it's indeed Arachni running, but doesn't bind to the ip:port. I'm using this ( as an example to build my rpcd server image.


  1. Support Staff 1 Posted by Tasos Laskos on 07 Dec, 2015 01:21 PM

    Tasos Laskos's Avatar

    Hey there,

    Actually, I've no idea, never tried Docket.
    Maybe a permission issue?


  2. 2 Posted by bewell on 07 Dec, 2015 01:27 PM

    bewell's Avatar

    I'm running it as sudo.. Should be fine.

    Btw, that example from above would start the webui and it works. So I was searching what's wrong with the rpcd.

  3. Support Staff 3 Posted by Tasos Laskos on 07 Dec, 2015 01:29 PM

    Tasos Laskos's Avatar

    Maybe some restriction at the container level?
    Is IPv4 available?

  4. 4 Posted by bewell on 07 Dec, 2015 01:31 PM

    bewell's Avatar

    Yes, docker starts its own network:

  5. Support Staff 5 Posted by Tasos Laskos on 07 Dec, 2015 06:02 PM

    Tasos Laskos's Avatar

    Is anything printed in the error logs?

  6. 6 Posted by bewell on 21 Dec, 2015 12:15 PM

    bewell's Avatar


    so the issue was that since arachni wants to bind to somekind of IP, but the IP of the host is invisible from docker containers, you have to parse it in the dockerfile as this:

    CMD ["/opt/arachni/bin/arachni_rpcd","--address",""]

    Maybe that will become useful for somebody :)

  7. Support Staff 7 Posted by Tasos Laskos on 21 Dec, 2015 11:15 PM

    Tasos Laskos's Avatar

    Thank you. :)

  8. Tasos Laskos closed this discussion on 21 Dec, 2015 11:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac