OS X El Capitan (10.11) support?

Jono's Avatar

Jono

03 Nov, 2015 08:54 PM

Hi there, I downloaded the 1.3.2-0.5.9 OS X package, and running it informs me that "Mac OSX 10.11 'El Capitan' is not supported"

Is there a timeframe for supporting the OS?
Would me switching to the nightlies be of benefit? (And yes, I am familiar with the risks of nightly builds, we run a very similar process internally)

Thanks!

  1. Support Staff 1 Posted by Tasos Laskos on 03 Nov, 2015 09:03 PM

    Tasos Laskos's Avatar

    Hello Jono,

    OSX 10.11 introduced a security measure that broke a very important dependency and I'm currently waiting for it to be fixed.

    There's an issue on Arachni's tracker you can follow in order to stay updated: https://github.com/Arachni/arachni/issues/619#issuecomment-145146328

    As for the nightlies they won't help, you can however try to build a package for your system with:

    wget -O - https://raw.github.com/Arachni/build-scripts/master/bootstrap.sh | bash
    

    This requires that you have a build environment though.

    Cheers,
    Tasos L.

  2. Tasos Laskos closed this discussion on 03 Nov, 2015 09:03 PM.

  3. Jono re-opened this discussion on 03 Nov, 2015 09:06 PM

  4. 2 Posted by Jono on 03 Nov, 2015 09:06 PM

    Jono's Avatar

    Fantastic, thanks :)
    I should have pretty much all deps for the required build environment, so I may give building it a go.

    Thanks!

  5. Support Staff 3 Posted by Tasos Laskos on 03 Nov, 2015 09:07 PM

    Tasos Laskos's Avatar

    No problem.

    I'm closing this discussion for now but if the build scripts give you any trouble feel free to re-open it.

    Cheers

  6. Tasos Laskos closed this discussion on 03 Nov, 2015 09:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac