Error when i tried to read a scan

ippolito julien's Avatar

ippolito julien

06 Feb, 2014 08:00 AM


When i tried to open a scan, i have an error in the web interface :
We're sorry, but something went wrong.

this is a copy of the production.log

Processing by ScansController#show as HTML
Parameters: {"id"=>"16"} Rendered shared/_share_form.html.erb (4.3ms) Rendered scans/_scan_sidebar.html.erb (15.6ms) Rendered scans/_editable_description.html.erb (1.8ms) Rendered shared/_share_form.html.erb (6.8ms) Rendered scans/_scan_group_form.html.erb (0.8ms) Rendered scans/_form_advanced_options_scheduling.html.erb (7.4ms) Rendered scans/_scan_schedule_form.html.erb (9.7ms) Rendered comments/_list.html.erb (0.1ms) Rendered comments/_form.html.erb (2.0ms) Rendered scans/_comments.html.erb (2.9ms) Rendered scans/_show_inactive.html.erb (21.7ms) Rendered scans/show.html.erb within layouts/application (64.0ms) Completed 500 Internal Server Error in 78ms

ActionView::Template::Error (undefined method delta_time' for nil:NilClass): 16: The scan completed in 17: <% end %> 18: 19: <%= %>. 20: </p> 21: 22: <% reports_links = reports_with_outfile. app/views/scans/_show_inactive.html.erb:19:in_app_views_scans__show_inactive_html_erb___1993059844349435069_59191700' app/views/scans/show.html.erb:69:in _app_views_scans_show_html_erb___1017452848704451963_47878940' app/controllers/scans_controller.rb:88:inshow'

thanks for your assist

  1. Support Staff 1 Posted by Tasos Laskos on 06 Feb, 2014 12:27 PM

    Tasos Laskos's Avatar

    Hi, which version are you using?

  2. 2 Posted by ippolito julien on 06 Feb, 2014 12:32 PM

    ippolito julien's Avatar

    Arachni v0.4.6 - WebUI v0.4.3

  3. Support Staff 3 Posted by Tasos Laskos on 06 Feb, 2014 12:36 PM

    Tasos Laskos's Avatar

    Thanks, I'll look into it and let you know.


  4. 4 Posted by ippolito julien on 06 Feb, 2014 12:48 PM

    ippolito julien's Avatar

    display seem faild on very long scan, on some quick scan i can see the report.
    I don't no if this info can help you

  5. Support Staff 5 Posted by Tasos Laskos on 06 Feb, 2014 01:15 PM

    Tasos Laskos's Avatar

    Yeah it looks like the scan completed successfully but there was a problem when trying to retrieve the report. Are there any other errors in the logfiles under system/logs/?

  6. 6 Posted by ippolito julien on 06 Feb, 2014 01:32 PM

    ippolito julien's Avatar

    no other log, some files in /system/logs/framework, but no error inside

  7. 7 Posted by ippolito julien on 06 Feb, 2014 02:14 PM

    ippolito julien's Avatar

    If i delete the line in error, i can open the scan in the ui,
    but i cannot get an html repport.

  8. Support Staff 8 Posted by Tasos Laskos on 06 Feb, 2014 02:16 PM

    Tasos Laskos's Avatar

    Yeah, the problem is that the report wasn't retrieved, which caused the error in the first place.

  9. 9 Posted by ippolito julien on 06 Feb, 2014 02:18 PM

    ippolito julien's Avatar

    if y send you the databases this can help you?

  10. Support Staff 10 Posted by Tasos Laskos on 06 Feb, 2014 02:22 PM

    Tasos Laskos's Avatar

    There's no need for that yet, however, could you please rerun the scan and see if you get the same error? If you do it means that it's reproducible and I'll then need the URL and profile you used so that I can debug it.
    If you don't, then that's a problem, but we'll cross that bridge when we get to it.


  11. 11 Posted by ippolito julien on 06 Feb, 2014 02:31 PM

    ippolito julien's Avatar

    the bug is reproductive but i test a site on no-production and cannot accessed on the web.
    in the profile i use the default profile update with login plugin.

  12. Support Staff 12 Posted by Tasos Laskos on 06 Feb, 2014 02:34 PM

    Tasos Laskos's Avatar

    And granting me temporary access is out of the question, right?

  13. 13 Posted by ippolito julien on 06 Feb, 2014 02:36 PM

    ippolito julien's Avatar

    very difficult, i weel tried to reproduce on other site

  14. 14 Posted by tir av on 25 Feb, 2014 06:19 PM

    tir av's Avatar

    This happened to me as well.
    When I "restarted" the scan (which created a new scan), I was able to access the report for my previous completed scan.
    This was consistent through scans of 2 different websites.

  15. Support Staff 15 Posted by Tasos Laskos on 25 Feb, 2014 06:58 PM

    Tasos Laskos's Avatar

    Scan revisions sort of share the reports, you're seeing merged results. Are you certain that you're not seeing only the new report?

  16. Tasos Laskos closed this discussion on 27 Jun, 2014 11:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac