We're sorry, but something went wrong.

Hacer Boy's Avatar

Hacer Boy

16 Mar, 2020 11:04 AM

Hello i am using kali linux update version and Arachni v1.5.1 - WebUI v0.5.12 it shows a error when i try to log in can any one help me about that

  1. 1 Posted by Me on 27 Mar, 2020 04:58 PM

    Me's Avatar

    I'm getting the same, log files shows the following -
    Started POST "/d/users/sign_in" for ::1 at 2020-03-27 16:43:34 +0000
    Processing by Devise::SessionsController#create as HTML
    Parameters: {"utf8"=>"✓", "authenticity_token"=>"6XyKKVhen3qPaeqe8tL9cc4EIbHIBV421oPWgG+mNYrG5bD+jofGYkSyODxgjfJjjeP+C3phFjcT+VRl/06MDQ==", "user"=>{"email"=>"[email blocked]", "password"=>"[FILTERED]", "remember_me"=>"0"}, "commit"=>"Sign in"} Completed 401 Unauthorized in 207ms (ActiveRecord: 0.4ms)
    Processing by Devise::SessionsController#new as HTML
    Parameters: {"utf8"=>"✓", "authenticity_token"=>"6XyKKVhen3qPaeqe8tL9cc4EIbHIBV421oPWgG+mNYrG5bD+jofGYkSyODxgjfJjjeP+C3phFjcT+VRl/06MDQ==", "user"=>{"email"=>"[email blocked]", "password"=>"[FILTERED]", "remember_me"=>"0"}, "commit"=>"Sign in"} Completed 500 Internal Server Error in 66ms (ActiveRecord: 0.0ms)

  2. 2 Posted by Riheja on 18 Apr, 2020 02:59 AM

    Riheja's Avatar

    I have the same mistake. Did you manage to fix it?

  3. 3 Posted by Dmitriy on 24 Apr, 2020 05:49 AM

    Dmitriy's Avatar

    Maybe, problem in sqlite3. Arachni can not connect to the db file. I can not find any sqlite file in program directory.

  4. 4 Posted by Nitin on 28 Apr, 2020 05:36 AM

    Nitin's Avatar

    Any solutions on this yet?

  5. 5 Posted by Brandon on 28 Apr, 2020 06:24 PM

    Brandon's Avatar

    Same error with no fix at the moment

  6. 6 Posted by karthik on 30 Apr, 2020 02:46 AM

    karthik's Avatar

    I have the same issue. The credentials in the README file are not working.

  7. 7 Posted by Carlos Vela on 19 May, 2020 08:24 PM

    Carlos Vela's Avatar

    x1000 help please

  8. 8 Posted by roman Serafin on 11 Jun, 2020 10:08 PM

    roman Serafin 's Avatar

    I have the same error when lifting the service. /arachni_web, send me the error We’re sorry, but went something wrong. I do not know what to do, help please.

    tengo el mismo error al levantar el servicio ./arachni_web, me envia el error We're sorry, but something went wrong. no se que hacer, ayuda por favor

  9. 9 Posted by celfInfinite on 17 Jun, 2020 09:36 AM

    celfInfinite's Avatar

    I have had the same problems for the past two days, i found this error in the log file, BCrypt::Errors::InvalidHash (invalid hash). it seems the generated hash passwords are invalid for both regular user and administrator. Help please

    OS: Arch Linux 5.6.15
    Virtual Machine: Oracle VM
    Kali Linux (VM) 5.6.0

  10. 10 Posted by ejus on 18 Sep, 2020 11:50 AM

    ejus's Avatar

    In your arachni dir edit the file system/gems/gems/bycrypt-3.1.11/lib/bcrypt/engine.rb
    Line 51:
    - __bc_crypt(secret.to_s, salt) + __bc_crypt(secret.to_s, salt).gsub(/(\n|\x00).*/, '') Change pass:
    ./arachni_web_change_password [email blocked] administrator Start arachni and login.

  11. 11 Posted by John on 07 Feb, 2021 12:27 AM

    John's Avatar

    I found that the best way was to truncate the size of the hash returned by __bc_crypt since it was adding a lot of extraneous characters, some of which was alpha. Modify the engine.rb file referred to in the above post to be

    __bc_crypt(secret.to_s, salt)[0...60]

    You can read https://j0hn88.wordpress.com/2021/02/06/rectify-it-arachni-web-appl... to see how I came to this conclusion

  12. 12 Posted by Eduardo Mineo on 26 Mar, 2021 09:31 AM

    Eduardo Mineo's Avatar

    Thanks, John (11). Your answer is the only solution that worked for me.

  13. 13 Posted by Ego on 12 Jan, 2024 12:01 AM

    Ego's Avatar

    Thank you so much John. Good explanation.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screenshot_2020-03-16_16-33-33.png 57.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac