authentication problems

Gabriel Gomez's Avatar

Gabriel Gomez

23 Apr, 2013 05:40 PM

Hi guys,

I'm trying to provide arachni with authentication credentials for an application I created and i'm following the "arachni_web -username -password" format that I found on the wiki but I get this error:
/Users/gabe/desktop/arachni- `start_tcp_server': no acceptor (port is in use or requires root privileges) (RuntimeError)

I'm not even sure if that's the right way to provide the login credentials, if it's not could you provide me details on how to do it the right way or how solve this error.

Thanks in advance,
Gabriel Gomez

  1. Support Staff 1 Posted by Tasos Laskos on 23 Apr, 2013 05:45 PM

    Tasos Laskos's Avatar

    Those options set the username and password for the Web interface not the scans. To configure scan settings you'll need to go to the "Settings" page of the interface.

    Also, this error is about another process already using the same port as the WebUI, 4567 I believe is the default, so make sure there isn't another WebUI instance running.

  2. 2 Posted by Gabriel Gomez on 23 Apr, 2013 05:58 PM

    Gabriel Gomez's Avatar

    Thanks for the fast response.

    I'm trying to connect directly to a JBoss application but under settings I only see proxy username and password and I'm not trying to connect through a proxy server. Any ideas?

  3. Support Staff 3 Posted by Tasos Laskos on 23 Apr, 2013 06:02 PM

    Tasos Laskos's Avatar

    The easy way to go about it is to login to the webapp and then pass those cookies to Arachni and configure it to exclude any logout-links.

    For more options you can see:

  4. 4 Posted by Gabriel Gomez on 23 Apr, 2013 06:16 PM

    Gabriel Gomez's Avatar

    Alright man I'll give that a shot and let u know how it goes.

  5. Support Staff 5 Posted by Tasos Laskos on 01 Jun, 2013 07:51 PM

    Tasos Laskos's Avatar

    Hey man, everything working out OK?

  6. 6 Posted by Gabriel Gomez on 01 Jun, 2013 09:43 PM

    Gabriel Gomez's Avatar

    Yes, I was actually able to figure it out. Sorry for not replying back.

    Thanks for the help! :)

  7. Support Staff 7 Posted by Tasos Laskos on 01 Jun, 2013 09:52 PM

    Tasos Laskos's Avatar

    No worries man, glad you got it working.

  8. Tasos Laskos closed this discussion on 01 Jun, 2013 09:52 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac