[ERROR] Directory and subdirectories

Frank's Avatar


25 Oct, 2017 05:26 PM


I have downloaded the arachni repo and I'm trying the run the ./arachni* commands. However, i see the below given error for all commands i.e. ./arachni, ./arachni_web, ./arachni_web_create_user and so no.

[ERROR] Directory and subdirectories must be writtable: /arachni-ui-web/config/component_cache

I've tried:
Changing the permission on the folder. Tried with sudo and even deleted the "arachni-ui-web folder. but still the sam error.

  1. Support Staff 1 Posted by Tasos Laskos on 29 Oct, 2017 05:27 AM

    Tasos Laskos's Avatar


    I'm not sure what to tell you, the directory must still not be writtable for some reason.
    Also, why did you delete the "arachni-ui-web" folder? Arachni can't work without it and it wouldn't solve the error.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac