[-] Invalid URL argument, please provide a full absolute URL and try again

aryanguenthner's Avatar

aryanguenthner

26 Sep, 2016 03:39 PM

Steps to reproduce error- > 1) Set variables, 2) Set path of arachni and desired configuration.

$SITE = example.com 
$TARGET = https://example.com 
$AUTOLOGINURL =  
$COOKIE =  
$PLATFORMS = iis,asp  

/opt/arachni/bin/arachni $TARGET --checks=sql_injection* --plugin=autologin:url=
$AUTOLOGINURL#'$COOKIE' --output-only-positives --platforms=$PLATFORMS --http-request-concurrency 7 --authorized-by "Internet Security" --http-user-agent "IE5: Internet Security" --report-save-path . $SITE.afr --output-debug 2> debug-$SITE.log   

[-] Invalid URL argument, please provide a full absolute URL and try again.
  1. 1 Posted by aryanguenthner on 26 Sep, 2016 03:43 PM

    aryanguenthner's Avatar

    Uploading Screenshot

  2. Support Staff 2 Posted by Tasos Laskos on 26 Sep, 2016 06:00 PM

    Tasos Laskos's Avatar

    Are you sure the variables are being set?
    I'm now sure what shell you're using, but can you try printing out the command to make sure that it run as intended?

  3. 3 Posted by aryanguenthner on 26 Sep, 2016 06:10 PM

    aryanguenthner's Avatar

    My full steps are included. I set the variables and still get the error. Can you please try to reproduce the error?

  4. Support Staff 4 Posted by Tasos Laskos on 26 Sep, 2016 06:14 PM

    Tasos Laskos's Avatar

    I can't reproduce it because it's not valid Bash syntax and I don't know what it may be.

    If you are trying to run it as Bash, you should be getting multiple errors even prior to the script getting to Arachni, although when it does get to Arachni, all variables will be empty, thus explaining the error you're seeing

    Does that make sense?

  5. 5 Posted by aryanguenthner on 26 Sep, 2016 06:33 PM

    aryanguenthner's Avatar

    Ok, cool. I will test again and let you know the outcome.

    Do you have any recommendations?

    Thanks,
    Aryan

  6. Support Staff 6 Posted by Tasos Laskos on 26 Sep, 2016 06:38 PM

    Tasos Laskos's Avatar

    You need to set the vars like so:

    SITE=example.com
    TARGET=https://example.com
    AUTOLOGINURL=
    COOKIE=
    PLATFORMS=iis,asp
    

    The Arachni options for autologin are wrong, it's missing parameters and check.

  7. 7 Posted by aryanguenthner on 26 Sep, 2016 08:20 PM

    aryanguenthner's Avatar

    That worked! I just modified the variables and we are doing awesome now. Thanks you can close the ticket!

  8. Tasos Laskos closed this discussion on 26 Sep, 2016 08:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac