Failed to "rake install"

Frederic's Avatar


21 Jul, 2016 07:20 AM


I need to install Arachni from source and install it to system (with rake install) but it fails with the following error :

rake aborted!
Couldn't install gem, run gem mypath/pkg/arachni-1.4.gem' for more detailed output /var/lib/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/gem_helper.rb:88:ininstall_gem' /var/lib/gems/2.3.0/gems/bundler-1.12.5/lib/bundler/gem_helper.rb:45:in block in install' /var/lib/gems/2.3.0/gems/rake-11.2.2/exe/rake:27:in'

If I try "gem mypath/pkg/arachni-1.4.gem", I got the following error :

ERROR: While executing gem ... (Gem::DependencyError)
Unresolved dependency found during sorting - nokogiri (>= 1.5.9) (requested by loofah-2.0.3)

It's related to this same issue :

I think the problem is that it's checking for nokogiri version "1.5.9" whereas the version "nokogiri (1.6.8.rc2)" is installed (from the specs) on my system. It's seems to be a bug with Rake or Gem...

$ gem query --local

... multi_json (1.12.1)
net-telnet (0.1.1)
nokogiri (1.6.8.rc2)
oj (2.14.6)
oj_mimic_json (1.0.1)

I tried to change it to an older version without "rc" (example : "1.6.7") in the arachni.gemspec file, it works well. Do you have a hard dependency with the version? Or is it possible to update the version in the specifications ?

(I tried with a newer version, but it fails ... It seems that I'm missing something (not expert with Ruby / Gem))

If it's not possible, do you have a solution to install the self-contained package within the system (example : /usr/local/bin/...) ?

  1. Support Staff 1 Posted by Tasos Laskos on 21 Jul, 2016 07:58 AM

    Tasos Laskos's Avatar

    There is an issue with the dependencies in the gem, your best bet is using the package.
    Instead of installing it to a location that needs root privileges you can just add its bin/ directory to the PATH env variable.

  2. Tasos Laskos closed this discussion on 03 Aug, 2016 02:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac