Issue running arachni

Ashutosh's Avatar


27 Apr, 2016 06:39 AM


I am trying to run arachni but I get below error. Not sure how to resolve it? It was working fine 2 days ago and all of a sudden I'm now getting this:

find: '/C': No such file or directory
find: '/I': No such file or directory
'"ruby.exe"' is not recognized as an internal or external command, operable program or batch file.

Any help?

  1. 1 Posted by Ashutosh on 27 Apr, 2016 06:40 AM

    Ashutosh's Avatar

    I am using windows system

  2. Support Staff 2 Posted by Tasos Laskos on 27 Apr, 2016 06:41 AM

    Tasos Laskos's Avatar


    Did you make any modifications to the package?
    Is there any more of the error output?


  3. 3 Posted by Ashutosh on 27 Apr, 2016 06:44 AM

    Ashutosh's Avatar

    No. I did not make any modification to the package. There isn't any more output. But If I install ruby as a standalone installer and run it, I get the error for kernal_require.rb module.

    I checked and I feel, currently this error gets thrown from setenv.bat file where it is setting up ruby's path to env variable. Not sure why this error comes up.

    I tried installing and running on different machine and no error there.


  4. Support Staff 4 Posted by Tasos Laskos on 27 Apr, 2016 06:47 AM

    Tasos Laskos's Avatar

    Can you please show me how you're running Arachni?
    Include the full command as well as the output exactly as it appears on the screen.

  5. 5 Posted by Ashutosh on 27 Apr, 2016 08:59 AM

    Ashutosh's Avatar

    I figured out the solution for this. Turns out I had cygwin installed on my machine and because of that "find" command was getting overridden. It wasn't taking windows find.exe and it was trying to invoke unix find command which gave that error.

    I replaced "find" with "%windir%\system32\FIND.exe" in setenv.bat file and it worked find for me.

  6. Support Staff 6 Posted by Tasos Laskos on 27 Apr, 2016 09:29 AM

    Tasos Laskos's Avatar

    Glad you got it working.


  7. Tasos Laskos closed this discussion on 27 Apr, 2016 09:29 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac