Web UI not starting on IPv4 - Sept. 05 nightly build

Bob's Avatar


08 Sep, 2015 03:40 PM

Running the most recent nightly build (as of right now) the WebUI opens a port on IPv6 but not IPv4. There are no error messages in the log related to starting the server or binding the port. I have the log level set to debug.

This is a fresh install. I wiped away the previous version of the PGSQL database and re-ran the db:setup. Running release versions previously never encountered this problem.

25836 ?        Rl     0:01  |   |   \_ ruby /packages/arachni-2.0dev-1.0dev/bin/../system/gems/bin/rackup /packages/arachni-2.0dev-1.0dev/bin/../system/arachni-ui-web/config.ru --port 9292 --env production
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp6       0      0 ::1:9292                :::*                    LISTEN      25836/ruby
2015-09-08 11:27:08.446356500 *** Starting arachni_web
2015-09-08 11:27:11.631204500 Puma 2.13.4 starting...
2015-09-08 11:27:11.631209500 * Min threads: 0, max threads: 16
2015-09-08 11:27:11.631225500 * Environment: production
2015-09-08 11:27:11.631225500 * Listening on tcp://localhost:9292
# Logfile created on 2015-09-08 11:27:10 -0400 by logger.rb/47272
  Schedule Load (0.9ms)  SELECT "schedules".* FROM "schedules" INNER JOIN "scans" ON "scans"."schedule_id" = "schedules"."id" WHERE "scans"."status" = $1 AND (start_at <= '2015-09-08 15:27:16.648041')  [["status", "scheduled"]]
  Scan Load (0.4ms)  SELECT "scans".* FROM "scans" WHERE "scans"."active" = $1  [["active", "t"]]
  Dispatcher Load (0.6ms)  SELECT "dispatchers".* FROM "dispatchers"
  1. Support Staff 1 Posted by Tasos Laskos on 08 Sep, 2015 04:11 PM

    Tasos Laskos's Avatar

    Turns out it's due to an updated dependency. Is it an issue though?

    The server is listening on localhost as instructed and achieves the expected result of responding when contacted via http://localhost:9292.

    If you wish it to bind to an IPv4 address you can do it as always with:

    bin/arachni_web -o
  2. 2 Posted by Bob on 08 Sep, 2015 06:40 PM

    Bob's Avatar

    In previous installations, the default was to start up on, so I was able to access the WebUI remotely without any specific configuration.

    Then there was a similar issue with the rpcd once I was able to access the WebUI. I tried to launch a scan using all defaults, and the production.log grew immense (28GB) very quickly. It was looping the same error text.

    Arachni::Reactor: Address family not supported by protocol - connect(2) for [::1]:7331
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection.rb:228:in `connect_nonblock'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection.rb:228:in `block in _connect'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/error.rb:26:in `call'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/error.rb:26:in `translate'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection.rb:227:in `_connect'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/tls.rb:82:in `block in _connect'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/error.rb:26:in `call'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/error.rb:26:in `translate'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor/connection/tls.rb:81:in `_connect'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:564:in `block in process_connections'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:563:in `each'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:563:in `process_connections'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:316:in `block in run'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:307:in `loop'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:307:in `run'
    Arachni::Reactor: /packages/arachni-2.0dev-1.0dev/system/gems/gems/arachni-reactor-0.1.0/lib/arachni/reactor.rb:349:in `block in run_in_thread'

    It was a similar issue, rpcd was binding to IPv6 and not IPv4, so I had to add the IPv4 declaration to the startup. That stopped the errors and allowed the scan to launch.

  3. Support Staff 3 Posted by Tasos Laskos on 08 Sep, 2015 06:43 PM

    Tasos Laskos's Avatar

    I wasn't aware that RPC communication was affected too, I'll have a look at this.
    Thanks for the feedback, I'll keep you posted.

  4. Support Staff 4 Posted by Tasos Laskos on 09 Sep, 2015 06:31 PM

    Tasos Laskos's Avatar

    I couldn't reproduce the RPCD issue, can you describe the setup and configuration please?

  5. Support Staff 5 Posted by Tasos Laskos on 30 Sep, 2015 02:37 PM

    Tasos Laskos's Avatar

    Couldn't find any issues, feel free to reopen if you'd like.

  6. Tasos Laskos closed this discussion on 30 Sep, 2015 02:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac