arachni-rpc 0.2.1.2 gem is causing issues

Mike's Avatar

Mike

23 Mar, 2015 08:33 PM

I rebuilt my ruby Arachni RPC client today and it pulled in the latest arachni-rpc gem which looks to have been updated on March 21. This new gem is causing my spec tests to hang on calls to 'dispatcher_light_spawn'. I'm not sure the exact cause but the execution gets stuck on line 86 of this https://github.com/Arachni/arachni/blob/master/lib/arachni/processe...

Reverting to version 0.2.1.1 of the arachni-rpc gem fixes the problem. I also noticed that specifying 0.2.1.1 of arachni-rpc ended up pulling in 'arachni-1.0.6' instead of 'arachni-1.0' in my gems folder... Not really sure why...

My working Gemfile looks like this now (before I was not specifying any versions).

gem 'arachni'
gem 'arachni-rpc', '0.2.1.1'

Anyway thanks in advance

  1. Support Staff 1 Posted by Tasos Laskos on 23 Mar, 2015 08:38 PM

    Tasos Laskos's Avatar

    The Arachni gem already pulls in the appropriate version of arachni-rpc (v0.2.1.1 for Arachni Framework 1.0.6), so you can remove the arachni-rpc entry from your Gemfile.

    You don't need to worry about compatible versions, that's what I'm for. :)

  2. Tasos Laskos closed this discussion on 23 Mar, 2015 08:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac