--scope-exclude-path issue

bewell's Avatar

bewell

20 Nov, 2014 03:21 PM

Hey,

it's the part II of the story here: https://github.com/Arachni/arachni/issues/520

So I defined that as you put there, but the scanner somehow didn't pick it up. Am I using it correctly? I was hoping that the scanner would take this pattern while inspecting the path, but it seems that's not the case.

The report is still full of paths like that:
Images/ui-bg_flat_0_aaaaaa_40x100.png
Images/ui-bg_glass_75_e6e6e6_1x400.png
Images/ui-icons_222222_256x240.png
bundles/jquerynew

  1. Support Staff 1 Posted by Tasos Laskos on 20 Nov, 2014 03:31 PM

    Tasos Laskos's Avatar

    Can you show me exactly how you're running it please?

  2. 2 Posted by bewell on 20 Nov, 2014 03:37 PM

    bewell's Avatar

    well, I'm adding --scope-exclude-pattern=Images --scope-exclude-pattern=bundles
    next to other arguments to my scan.

    The whole line looks like that variables defined plus the arguments above:
    arachni $TEST_URL --report-save-path=$REPORTS_PARAM_RAW --scope-extend-paths=$TESTS_FOLDER/$URL_BASE"_URLs.txt" --http-user-agent=$User_Agent

  3. Support Staff 3 Posted by Tasos Laskos on 20 Nov, 2014 03:45 PM

    Tasos Laskos's Avatar

    Strange, does it work when using the other way I mentioned? As a regular expression that combines both?

  4. 4 Posted by bewell on 20 Nov, 2014 03:56 PM

    bewell's Avatar

    I thought that's for cases when you have both values in the path. It's working though, thanks!

  5. Support Staff 5 Posted by Tasos Laskos on 20 Nov, 2014 03:59 PM

    Tasos Laskos's Avatar

    No problem, you should lookup regular expressions if you're going to be using those scope options extensively, it'll save you some time.

    Happy scanning. :)

  6. Tasos Laskos closed this discussion on 20 Nov, 2014 03:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac