arachni_web fails to start with latest nightly

Mike's Avatar

Mike

17 Oct, 2013 05:31 PM

Just a heads up that arachni_web does not start with the latest nightly build (nor has it worked for the past week or so). I can send you debug output from my machine if you cannot reproduce.

Thanks,

  1. Support Staff 1 Posted by Tasos Laskos on 17 Oct, 2013 06:37 PM

    Tasos Laskos's Avatar

    You are right, it's a simple namespace issue, for some reason it only happens when the production environment but it's an easy fix.

    Will patch and push the nightlies and let you know when it's ready.

    Cheers

  2. Support Staff 2 Posted by Tasos Laskos on 17 Oct, 2013 08:59 PM

    Tasos Laskos's Avatar

    Nope, it's something else, haven't been able to work it out yet. Does it just seem to freeze for you as well?

  3. 3 Posted by Mike on 17 Oct, 2013 09:22 PM

    Mike's Avatar

    Yea -- I turned on debug mode and there were a number of errors...

    Attached debug output

  4. Support Staff 4 Posted by Tasos Laskos on 17 Oct, 2013 09:59 PM

    Tasos Laskos's Avatar

    Rather embarrassingly, it works just fine but for some reason the familiar output of:

    >> Thin web server (v1.5.1 codename Straight Razor)
    >> Maximum connections set to 1024
    >> Listening on 0.0.0.0:9292, CTRL+C to stop
    

    ...doesn't appear.

    Weird, but not as serious as I initially thought.

  5. Support Staff 5 Posted by Tasos Laskos on 17 Oct, 2013 11:08 PM

    Tasos Laskos's Avatar

    Seems like the relevant bug has been fixed: https://github.com/macournoyer/thin/issues/201

    We'll just have to wait until the next minor thin version.

    Thanks again for reporting this Mike.

  6. Tasos Laskos closed this discussion on 17 Oct, 2013 11:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac