RPC over a WAN acts strangely

Mike's Avatar


25 Sep, 2013 09:07 PM

When running rpcd in a separate network from the rpc client, the client is unable to route to the rpcd after the initial connection setup in a standard configuration. The rpcd binds to the eth0 ip address (or just fine by doing rpcd --address --port 7331. I am able to initiate the rpc connection over the public internet just fine and can see the connection when following the server stdout. However, the next step is for the rpc client to initiate a new connection back to the rpcd and it tries to connect to the bound IP of the rpcd which is in this example. I end up getting a [-] Connection closed [Errno::ETIMEDOUT] on the client side.

I am able to work around this issue by setting the hosts file on the rpcd server to map to a FQDN and then map the external IP address of the rpcd server to the same FQDN on the client side. Then I run rpcd --address my.fqdn.com --port 7331 on the server which listens on and also tells the client to connect to my.fqdn.com which it will resolve to the external IP.

Obviously this is not ideal ... Hopefully my explanation was not too confusing.


  1. Support Staff 1 Posted by Tasos Laskos on 25 Sep, 2013 09:14 PM

    Tasos Laskos's Avatar

    Is there a reason why you don't want to provide your WAN IP address as the Dispatcher's --address option?

  2. 2 Posted by Mike on 25 Sep, 2013 09:39 PM

    Mike's Avatar

    eth0 only knows of its internal network and it cannot bind to the WAN IP... It's running NAT'd behind some Amazon magic.

    Attached is the trace when I tried it anyway (replaced real WAN IP with

  3. Support Staff 3 Posted by Tasos Laskos on 25 Sep, 2013 09:47 PM

    Tasos Laskos's Avatar

    That's a good point, but since the Dispatchers need to know of their external IP address I'll have to add a separate option for that.

    I'll let you know when I have this ready.


  4. Support Staff 4 Posted by Tasos Laskos on 25 Sep, 2013 11:16 PM

    Tasos Laskos's Avatar

    I've finished it, now running some tests and will be in tomorrow's nightlies for you to check out. Will update this ticket when the nightlies are up.


  5. Support Staff 5 Posted by Tasos Laskos on 26 Sep, 2013 09:26 AM

    Tasos Laskos's Avatar

    Ok, the update is in the nightlies, you can use the --external-address option to specify the address the Dispatcher should advertise to its clients.

    Let me know how it works.


  6. 6 Posted by Mike on 27 Sep, 2013 02:46 PM

    Mike's Avatar

    Confirmed that it works now.


  7. Support Staff 7 Posted by Tasos Laskos on 27 Sep, 2013 02:47 PM

    Tasos Laskos's Avatar

    No worries man, glad it's working. :)

  8. Tasos Laskos closed this discussion on 27 Sep, 2013 02:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac