Installing Arachni - OSX

Ricky's Avatar

Ricky

03 Oct, 2012 04:12 PM

Attempting to install Arachni on OSX Mountain Lion and receive the following error: dm-core requires addressable (~> 2.2.6, runtime)

Any ideas?

$ gem --version 1.8.24

$ ruby -v ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin12.2.0]

  1. Support Staff 1 Posted by Tasos Laskos on 03 Oct, 2012 04:20 PM

    Tasos Laskos's Avatar

    Hm, can't reproduce.

    How are you trying to install it? Are you using the source code or the gem?
    Also, is there any reason why you didn't prefer to use the self-contained OSX package?

    PS. Full console output of what you were doing might help.

  2. Support Staff 2 Posted by Tasos Laskos on 03 Oct, 2012 04:22 PM

    Tasos Laskos's Avatar

    Do you happen to have a version of addressable (> 2.2) already installed by any chance?
    If you were using RVM you might want to give Arachni its own gemset.

  3. 3 Posted by Ricky on 03 Oct, 2012 04:27 PM

    Ricky's Avatar

    Extremely fast support - Wow. I just tried the self-contained OSX package and running a scan now. I was trying to use the gem, but that might have been the problem.

    I was able to compile this a bit ago on my Backtrack VM and loved the scanner. Can't wait to see how it performs in OSX.

    Thanks for the quick response.

  4. Support Staff 4 Posted by Tasos Laskos on 03 Oct, 2012 04:30 PM

    Tasos Laskos's Avatar

    No problem man, glad you got it working. :)

  5. Tasos Laskos closed this discussion on 03 Oct, 2012 04:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac